Wir nutzen Cookies, um Ihnen eine optimale Nutzung dieser Webseite zu ermöglichen. Mehr Informationen finden Sie im Datenschutzhinweis. Wir nehmen an, dass Sie damit einverstanden sind, falls Sie diese Webseite weiter besuchen.

Ihre Cookie-Einstellungen
Ihre Einstellungen wurden aktualisiert.
Damit die Änderungen wirksam werden, löschen Sie bitte Ihre Browser-Cookies und den Cache und laden dann die Seite neu.

Werk #10447: agent_kubernetes: use new API versions

KomponenteChecks & Agents
Titelagent_kubernetes: use new API versions
Datum2019-10-28 13:34:30
Checkmk EditionCheckmk Raw Edition (CRE)
Checkmk Version1.6.0p6,1.7.0i1
LevelTrivial Change
KlasseBug Fix
KompatibilitätIncompatible - Manual interaction might be required

The Kubernetes release 1.16 deprecated two API endpoints. To honor these deprecations the agent_kubernetes now uses the recommended new API endpoints by default. All Kubernetes versions since 1.9 support these new API endpoints.

To grant Checkmk access to the new API endpoints an updated version of the check_mk_rbac.yaml has to be applied.

If you have a Kubernetes version >= 1.16 and use a special agent prior to this werk a NotFound (404) error will be returned.

If you do not apply the updated check_mk_rbac.yaml the special agent will fall back to the old API version to be backwards compatible.