Wir nutzen Cookies, um Ihnen eine optimale Nutzung dieser Webseite zu ermöglichen. Mehr Informationen finden Sie im Datenschutzhinweis. Wir nehmen an, dass Sie damit einverstanden sind, falls Sie diese Webseite weiter besuchen.

Ihre Cookie-Einstellungen
Ihre Einstellungen wurden aktualisiert.
Damit die Änderungen wirksam werden, löschen Sie bitte Ihre Browser-Cookies und den Cache und laden dann die Seite neu.

Werk #6340: Fixed debian agent package incompatibilities

KomponenteCore & Setup
TitelFixed debian agent package incompatibilities
Datum2018-07-10 12:14:54
Checkmk EditionCheckmk Raw Edition (CRE)
Checkmk Version1.4.0p35,1.6.0b1,1.5.0b9
LevelTrivial Change
KlasseBug Fix
KompatibilitätKompatibel - benötigt kein manuelles Eingreifen

The debian agent package shipped with Check_MK (located in share/check_mk/agent/*.deb) was not compatible with older Debian/Ubuntu version because it used xz as compression algorithm for the control files.

When trying to install such a package an error like this occurred:

dpkg-deb: error: archive 'check-mk-agent_1.4.0p34-1_all.deb' contains not understood data member control.tar.xz, giving up

We have now changed the compression of the whole package to gzip which should make the package compatible to such systems again.