Wir nutzen Cookies, um Ihnen eine optimale Nutzung dieser Webseite zu ermöglichen.Visit our Privacy Policy to learn more. Wir nehmen an, dass Sie damit einverstanden sind, falls Sie diese Webseite weiter besuchen.

Ihre Cookie-Einstellungen
Ihre Einstellungen wurden aktualisiert.
Damit die Änderungen wirksam werden, löschen Sie bitte Ihre Browser-Cookies und den Cache und laden dann die Seite neu.

Werk #6341: Fixed 'SyntaxError: invalid syntax' warning when installing bakery packages on older systems

KomponenteAgent Bakery
TitelFixed "SyntaxError: invalid syntax" warning when installing bakery packages on older systems
Datum2018-07-10 12:34:30
Checkmk EditionCheckmk Enterprise Edition (CEE)
Checkmk Version1.4.0p35,1.6.0b1,1.5.0b9
LevelTrivial Change
KlasseBug Fix
KompatibilitätKompatibel - benötigt kein manuelles Eingreifen

When installing agent bakery RPMs/DEBs an error message "SyntaxError: invalid syntax" could occur. This was caused by a pre-install script that should warn about incompatible Python versions. This script was incompatible to older Python versions, like Python 2.4.

At least in case of the RPMs the installation did complete despite of this message.