Werk #8705: RPM/DEB: Verifying python version during install when shipping python plugins

KomponenteAgent Bakery
TitelRPM/DEB: Verifying python version during install when shipping python plugins
Datum2017-02-20 09:28:11
Checkmk EditionCheckmk Enterprise Edition (CEE)
Checkmk Version1.4.0i3
LevelTrivial Change
KlasseBug Fix
KompatibilitätKompatibel - benötigt kein manuelles Eingreifen

The agent packages shipped by the agent bakery may contain agent plugins that need a python interpreter on the target system. The Debian- and RPM-packages built by the agent bakery are now verifying that the python interpreter is installed as 'python' in the PATH and also verify that this python is Python 2.x. The later check is needed because the Python agent plugins are currently only Python 2.x compatible.